Home Gallery Resources The Team Rules chat Login Register
Pages: [1]
Author Topic: BrawlBox Animation Issue  (Read 174 times)
0 Members and 1 Guest are viewing this topic.
tyleto
Advanced Kitten
***
Offline Offline

Posts: 21


texture hacks and csps yay


View Profile WWW Awards
« on: October 24, 2017, 06:50:48 PM »


So I've been getting back into animating recently, and I'm not sure if it's just the way I do it or it's a glitch or setting in the program. How I'd usually animate is have the starting point at frame 1, and the next motion 5-15 frames ahead so the program automatically moves the bones so I don't have to do it frame by frame. However, there's an issue I don't think I had before (using BrawlBox v0.78 (I don't think I had an issue with this in earlier versions?)). If I do more than one of those movements, the previous one will have issues with bones that I did not edit. Example, I'm editing a Mario animation right now and all I did was move his current pose from frame 1 up and over until frame 23, then I added in a flipping animation and when I played it, the frames between 1 and 23 were messing up, moving the knees fingers. I did not edit the knees in either frame 1 or 3 but I did edit the fingers in both (they're the same pose, just different translations). Any way I could possibly fix this? Or am I just animating the lazy way and actually do it frame by frame, although some kind of fix would be optimal.
Logged

I usually post updates on stuff on my Twitter so check that out if you're interested
www.twitter.com/tyleto

If you wanna talk about something please do it on my Facebook, you'll get more frequent replies.
http://www.facebook.com/tyletwo

windhunter7
BrawlVault Gatekeeper
Angel Kitten
***
Online Online

Posts: 3146


Finished Part 2 of the Model Porting Tutorial!

  • Awards Famous Hacker Heart Container Helping Hand >9000 Active Contributor

  • View Profile WWW Awards
    « Reply #1 on: October 24, 2017, 08:05:36 PM »


    Even though I don't know why it's doing that, I do know that if you animate with Blender and convert the animation with Maya, if done correctly, it's glitch free; If this would work as a workaround, just ask me, and I can give you the steps to do it
    Logged


    tyleto
    Advanced Kitten
    ***
    Offline Offline

    Posts: 21


    texture hacks and csps yay


    View Profile WWW Awards
    « Reply #2 on: October 24, 2017, 09:29:34 PM »


    Even though I don't know why it's doing that, I do know that if you animate with Blender and convert the animation with Maya, if done correctly, it's glitch free; If this would work as a workaround, just ask me, and I can give you the steps to do it

    I have a laptop and I've heard the laptop version of Blender is harder to use than the PC version, I've tried it myself for a render but I couldn't quite get it. I eventually did find a fix though. I just copied 1-23 frame before adding in the 29 frame pose. It worked and it's all flowing smoothly now (I'm pretty sure this won't be a fix for all occasions). Thanks for the advice though!
    Logged

    I usually post updates on stuff on my Twitter so check that out if you're interested
    www.twitter.com/tyleto

    If you wanna talk about something please do it on my Facebook, you'll get more frequent replies.
    http://www.facebook.com/tyletwo

    Pages: [1]
    Print
    Jump to: